A note about Browsers

Technology moves so quickly and sometimes we as users forget to do one important thing to keep pace: upgrade!

We want to make sure you can actively participate in the NCB Forum. Please note that the following are supported browsers for NCB Forum participants:

* Microsoft Internet Explorer (no version older than 7.0)

* Mozilla Firefox (no version older than 3.0)

* Google Chrome (no version older than 4.0)

* Safari (no version older than 3.0+)

* Opera

Check your browser today to see that you are using a current version. Doing so will improve your experience here on the NCB Forum and across the Internet!